Windows media player library not updating

There are 1000 albums so I would rather not have to load the images one at a time. Over the years I have added the album art manually to over 2500 songs (embedded within the MP3, not externally).When I play the music in WPM11 the album art displays (when using Album Art as the visualization). Media player is so awful it has now started to get me upset.

To manually add the album art, do the following: First, find the album covers using any search engine you like and then save it on your PC.

Then, open Windows Media Player, navigate through your music library and find that specific album.

Sometimes it takes time for the album art to appear.

Just wait or browse out of the folder and come back and the album art will show up.

And when I go into library to do it manually,the album is not in internet connection is fine,so I really don't know what is happening. I've been able to copy and paste album art without a problem BUT it doesn't always "stick"--what's going on?

I've tried going into Now Playing,more options & ticking Connect to the Internet,it's not that either. I've been working here for hours to get the correct album art just to find that the image I've pasted onto one album has also pasted onto many others. If so, let me know because I'm getting REALLY frustrated!If the search will return no results, you will have to update the existing information and include what you know about it.In this example, both the album and the artist are unknown.If all the selected tracks are from the same album, select the appropriate option and click on .The wizard will start searching for the album in its database.To add the album art, just drag and drop the covers on top of the album. Either way, the next time you open that album in Windows Media Player, you will be able to see the covers.

Tags: , ,